#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<img[^>]+data-src=("[^"]+")[^>]*>"
Local $sString = "<img src="old.jpg" data-src="new.jpg">" & @CRLF & _
"<img data-src="new2.jpg" src="old2.jpg">"
Local $sSubst = "<img src=$1 data-src=$1>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)