# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<img[^>]+data-src=(\"[^\"]+\")[^>]*>"
test_str = ("<img src=\"old.jpg\" data-src=\"new.jpg\">\n"
"<img data-src=\"new2.jpg\" src=\"old2.jpg\">")
subst = "<img src=$1 data-src=$1>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.