#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^\d+)(\s.+\s)(\d{1,3})(,\d{3})*(\.\d+)(\s)(\d{1,3})(,\d{3})*(\.\d+)"
Local $sString = "1 DESCHUTES BREWERY / MOUNTAIN ROOM 4,753.58 58,006.91" & @CRLF & _
"2 NINKASI BREWING COMPANY / NINKASI DISTRIBUTION 6,011.37 44,171.82" & @CRLF & _
"3 10 BARREL BREWING COMPANY 2,795.45 34,440.21" & @CRLF & _
"4 HOP VALLEY BREWING CO 3,402.00 32,589.00" & @CRLF & _
"5 FULL SAIL BREWING COMPANY 919.18 22,799.42" & @CRLF & _
"6 PORTLAND BREWING / PTLD BREWING CO / TAPROOM & PYRAMID BRWY 1,570.34 21,090.13" & @CRLF & _
"7 BONEYARD BEER 2,046.12 20,857.07" & @CRLF & _
"8 2 TOWNS CIDERHOUSE 1,239.23 14,921.30" & @CRLF & _
"9 PELICAN BREWING CO 1,371.48 14,856.30" & @CRLF & _
"10 BREAKSIDE BREWERY 1,476.48 13,991.01" & @CRLF & _
"11 ROGUE ALES BREWERY 1,430.40 12,918.72" & @CRLF & _
"12 FORT GEORGE BREWERY & PUBLIC HOUSE 1,118.21 12,096.63" & @CRLF & _
"13 GOOD LIFE BREWING COMPANY 519.55 10,799.84" & @CRLF & _
"14 HOPWORKS URBAN BREWERY 1,219.32 9,348.90" & @CRLF & _
"15 WORTHY BREWING COMPANY 699.61 9,254.13" & @CRLF & _
"16 PFRIEM FAMILY BREWERS 925.24 9,116.80" & @CRLF & _
"17 CRUX FERMENTATION PROJECT 545.00 8,266.91" & @CRLF & _
"18 BRIDGEPORT BREWING COMPANY 692.35 7,484.79" & @CRLF & _
"19 BUOY BEER COMPANY 875.86 6,961.40" & @CRLF & _
"20 CALDERA BREWING COMPANY 313.40 6,555.02" & @CRLF & _
"21 ECLIPTIC BREWING 776.37 6,183.25" & @CRLF & _
"22 DOUBLE MOUNTAIN BREWERY 550.28 6,065.78" & @CRLF & _
"23 SUNRIVER BREWING COMPANY 675.99 5,994.90" & @CRLF & _
"24 OAKSHIRE BREWING 773.15 5,911.58" & @CRLF & _
"25 SILVER MOON BREWING 213.36 5,896.51" & @CRLF & _
"26 LAURELWOOD PUBLIC HOUSE & BREWERY 298.02 5,515.04" & @CRLF & _
"27 THREE CREEKS BREWING CO 355.11 5,030.06" & @CRLF & _
"28 CASCADE LAKES BREWING CO 439.24 4,970.97" & @CRLF & _
"29 ATLAS CIDER 471.00 4,784.13" & @CRLF & _
"30 EDGEFIELD BREWERY 356.12 4,462.93" & @CRLF & _
"31 PORTLAND CIDER CO 334.02 4,227.80" & @CRLF & _
"32 BAKER CITY BREWING COMPANY 417.96 3,841.11" & @CRLF & _
"33 BLOCK 15 BREWERY & TAP ROOM 421.45 3,792.92" & @CRLF & _
"34 TERMINAL GRAVITY BREWING 391.51 3,576.55" & @CRLF & _
"35 GILGAMESH BREWING 237.18 3,512.94" & @CRLF & _
"36 BASE CAMP BREWING COMPANY 253.83 2,968.81" & @CRLF & _
"37 ALAMEDA BREWING CO 199.48 2,906.16" & @CRLF & _
"38 WILD RIDE BREWING 233.19 2,768.15" & @CRLF & _
"39 BURNSIDE BREWING COMPANY 298.47 2,370.81" & @CRLF & _
"40 OCCIDENTAL BREWING COMPANY 203.08 2,356.37" & @CRLF & _
"41 EX NOVO BREWING CO 214.54 2,255.08" & @CRLF & _
"42 GIGANTIC BREWING COMPANY 230.66 2,252.09" & @CRLF & _
"43 DESCHUTES BREWERY & PUBLIC HOUSE 249.40 1,966.51" & @CRLF & _
"44 BLUE MOUNTAIN CIDER COMPANY 413.26 1,863.05" & @CRLF & _
"45 5TH QUADRANT 149.02 1,804.65" & @CRLF & _
"46 EDGEFIELD WINERY 166.73 1,769.65" & @CRLF & _
"47 CRUX 219.51 1,734.94" & @CRLF & _
"48 LUCKY LABRADOR BREW PUB 175.27 1,712.27" & @CRLF & _
"49 FAT HEAD'S BREWERY 164.64 1,681.22" & @CRLF & _
"50 RAM RESTAURANT & BREWERY 156.25 1,607.20" & @CRLF & _
"51 ORDNANCE BREWING 113.11 1,435.91" & @CRLF & _
"52 ANCESTRY BREWING 139.82 1,415.76" & @CRLF & _
"53 MCMENAMIN'S KENNEDY SCHOOL 109.00 1,331.25" & @CRLF & _
"54 CORNELIUS PASS ROADHOUSE 140.75 1,326.50" & @CRLF & _
"55 GOLDEN VALLEY BREWERY & PUB 131.07 1,311.08" & @CRLF & _
"56 CRYSTAL BALLROOM & BREWERY 117.50 1,292.75" & @CRLF & _
"57 CULMINATION BREWING COMPANY 100.36 1,239.80" & @CRLF & _
"58 THE CREAMERY BREW PUB & GRILL 67.51 1,233.37" & @CRLF & _
"59 MIGRATION BREWING CO 130.00 1,180.25" & @CRLF & _
"60 SANTIAM BREWING 84.47 1,174.96" & @CRLF & _
"61 ZOIGLHAUS BREWING COMPANY 111.79 1,113.53" & @CRLF & _
"62 FALLING SKY BREWHOUSE 131.95 1,112.52" & @CRLF & _
"63 ROGUE EASTSIDE PUB & PILOT BREWERY 17.86 1,105.70" & @CRLF & _
"64 FEARLESS BREWING CO & TAP HOUSE 97.19 1,102.54" & @CRLF & _
"65 WILD RIVER BREWING & PIZZA CO 129.75 1,075.30" & @CRLF & _
"66 WILDCRAFT CIDER WORKS 64.89 1,054.72" & @CRLF & _
"67 MAZAMA BREWING COMPANY 137.34 1,054.34" & @CRLF & _
"68 KELLS BREW PUB 81.75 1,046.60" & @CRLF & _
"69 RIVERBEND BREWING 83.94 1,037.36" & @CRLF & _
"70 MCMENAMIN'S OLD ST FRANCIS SCHOOL 91.50 1,007.00" & @CRLF & _
"71 STEELHEAD BREWERY & CAFE 106.20 997.30" & @CRLF & _
"72 ROYALE BEER COMPANY 82.90 996.50" & @CRLF & _
"73 CLAIM 52 BREWING 107.79 994.42" & @CRLF & _
"74 COLDFIRE BREWING 94.08 987.56" & @CRLF & _
"75 REDHOOK ALE / WIDMER BROTHERS / KONA BREWING 92.05 967.81" & @CRLF & _
"76 HEATER ALLEN BREWING 83.54 966.86" & @CRLF & _
"77 OLD TOWN BREWING CO 72.81 958.62" & @CRLF & _
"78 ARCH ROCK BREWING COMPANY 86.67 958.54" & @CRLF & _
"79 MT HOOD BREWING CO 50.72 868.13" & @CRLF & _
"80 7 DEVILS BREWING CO 80.08 857.24" & @CRLF & _
"81 STORMBREAKER BREWING 69.68 852.48" & @CRLF & _
"82 WALKABOUT BREWING COMPANY 94.00 840.00" & @CRLF & _
"83 FIRE ON THE MOUNTAIN BUFFALO WINGS 80.50 828.25" & @CRLF & _
"84 SASQUATCH BREWERY 65.29 815.66" & @CRLF & _
"85 ROCK BOTTOM BREWERY 55.25 812.40" & @CRLF & _
"86 CIDER RIOT! 61.01 802.08" & @CRLF & _
"87 NOOKIE'S RESTAURANT & BREWERY / HERMISTON BREWING COMPANY 79.50 785.75" & @CRLF & _
"88 BEND BREWING COMPANY 78.00 755.60" & @CRLF & _
"89 OAK HILLS BREW PUB 77.75 715.75" & @CRLF & _
"90 GREAT NOTION BREWING & BARREL HOUSE 60.10 707.24" & @CRLF & _
"91 UPRIGHT BREWING COMPANY 73.40 704.60" & @CRLF & _
"92 GROUND BREAKER BREWING 44.92 704.34" & @CRLF & _
"93 PLANKTOWN BREWING CO 65.78 664.60" & @CRLF & _
"94 STICKMEN BREWERY & SKEWERY 65.59 660.54" & @CRLF & _
"95 JOHN BARLEYCORNS 55.00 660.00" & @CRLF & _
"96 RUSTY TRUCK BREWING COMPANY / ROADHOUSE 101 44.16 647.78" & @CRLF & _
"97 OREGON CITY BREWING COMPANY 57.59 641.22" & @CRLF & _
"98 PUBLIC COAST BREWING COMPANY 66.75 622.70" & @CRLF & _
"99 MCMENAMIN'S WEST LINN 42.00 619.75" & @CRLF & _
"100 MCMENAMIN'S ROSEBURG 66.00 618.00" & @CRLF & _
"101 CASCADE BREWING BLENDING HOUSE 26.82 617.05" & @CRLF & _
"102 CALAPOOIA BREWING CO 63.00 589.50" & @CRLF & _
"103 SILVER MOON BREWERY AND BREW PUB 92.63 585.01" & @CRLF & _
"104 LIGHTHOUSE BREW PUB 48.25 584.50" & @CRLF & _
"105 VAGABOND BREWING 72.34 577.87" & @CRLF & _
"106 FULTON PUB & BREWERY 66.00 574.50" & @CRLF & _
"107 SKY HIGH BREWING AND PUB 46.21 565.97" & @CRLF & _
"108 DE GARDE BREWING 45.61 557.21" & @CRLF & _
"109 ANDREW & STEVE'S CHARTROOM / ASTORIA BREWING CO 25.00 555.11" & @CRLF & _
"110 HIGH STREET BREWERY & CAFE 42.50 541.75" & @CRLF & _
"111 VERTIGO BREWING 39.13 534.82" & @CRLF & _
"112 TWO KILTS BREWING CO 46.28 524.00" & @CRLF & _
"113 PRODIGAL SON BREWERY & PUB 53.75 517.50" & @CRLF & _
"114 PINTS 62.05 506.24" & @CRLF & _
"115 THE OLD MARKET PUB & BREWERY 45.00 495.00" & @CRLF & _
"116 HILLSDALE BREWERY & PUBLIC HOUSE 53.75 484.25" & @CRLF & _
"117 SAM BOND'S BREWING CO 40.94 471.61" & @CRLF & _
"118 OLD 99 BREWING CO 48.66 468.25" & @CRLF & _
"119 MCMENAMIN'S CEDAR HILLS PUB 53.50 465.00" & @CRLF & _
"120 RED TANK CIDER COMPANY 21.10 461.34" & @CRLF & _
"121 THOMPSON BREWERY & PUBLIC HOUSE 35.25 450.75" & @CRLF & _
"122 HIGHLAND PUB & BREWERY 29.25 437.25" & @CRLF & _
"123 RAM RESTAURANT AND BREWERY 38.00 434.00" & @CRLF & _
"124 BILL'S TAVERN & BREWHOUSE 45.50 429.00" & @CRLF & _
"125 DELUXE BREWING COMPANY / SINISTER DISTILLING COMPANY 33.80 417.48" & @CRLF & _
"126 VANGUARD BREWING COMPANY 47.33 406.48" & @CRLF & _
"127 G MAN BREWERY 78.00 397.50" & @CRLF & _
"128 CLIMATE CITY BREWING CO 33.67 395.67" & @CRLF & _
"129 MAX'S FANNO CREEK BREWPUB 22.25 391.50" & @CRLF & _
"130 BLOCK 15 37.91 379.41" & @CRLF & _
"131 STANDING STONE BREWING CO 19.84 378.24" & @CRLF & _
"132 CHETCO BREWING COMPANY 31.17 376.67" & @CRLF & _
"133 MCMENAMIN'S ON MONROE 33.75 370.75" & @CRLF & _
"134 MONKLESS BELGIAN ALES 34.88 354.03" & @CRLF & _
"135 ALAMEDA BREWHOUSE 40.00 350.00" & @CRLF & _
"136 MONTAVILLA BREW WORKS 33.00 342.00" & @CRLF & _
"137 CASCADE BREWING COMPANY / RACCOON LODGE & BREWPUB 35.20 342.00" & @CRLF & _
"138 IMMERSION BREWING 29.18 338.41" & @CRLF & _
"139 HAIR OF THE DOG BREWING CO 48.43 337.99" & @CRLF & _
"140 FOX TAIL CIDER 28.39 322.89" & @CRLF & _
"141 BRICKTOWNE BREWING COMPANY 29.52 316.19" & @CRLF & _
"142 GRAIN STATION BREW WORKS 31.19 315.48" & @CRLF & _
"143 COLUMBIA RIVER BREWING COMPANY 46.00 309.50" & @CRLF & _
"144 THOMPSON CREEK ORGANICS 52.21 298.41" & @CRLF & _
"145 PELICAN PUB 22.37 291.45" & @CRLF & _
"146 BACKSIDE BREWING 25.70 277.75" & @CRLF & _
"147 ELK HORN BREWERY 24.75 272.09" & @CRLF & _
"148 NATIAN BREWERY 16.83 269.73" & @CRLF & _
"149 FREEBRIDGE BREWING 24.60 269.70" & @CRLF & _
"150 VIKING BRAGGOT COMPANY 28.88 268.18" & @CRLF & _
"151 BAUMAN'S CIDER 52.90 266.75" & @CRLF & _
"152 COIN TOSS BREWING COMPANY 33.00 264.02" & @CRLF & _
"153 WAYFINDER BEER 67.16 261.39" & @CRLF & _
"154 LEVEL BEER 134.12 259.85" & @CRLF & _
"155 DRAPER BREWING 17.00 247.00" & @CRLF & _
"156 BRIDGE 99 BREWERY 28.00 242.00" & @CRLF & _
"157 JD'S SPORTS PUB 36.00 240.50" & @CRLF & _
"158 OBLIVION BREWING CO 45.12 237.20" & @CRLF & _
"159 RUSE BREWING 33.50 231.70" & @CRLF & _
"160 WOLF TREE BREWERY 21.00 231.30" & @CRLF & _
"161 UPTOWN MARKET 17.88 229.85" & @CRLF & _
"162 BARLEY BROWN'S BREW PUB 23.21 220.51" & @CRLF & _
"163 SALEM ALE WORKS 20.72 212.41" & @CRLF & _
"164 MIA & PIA'S PIZZERIA & BREWHOUSE 20.50 204.00" & @CRLF & _
"165 DRINKING HORSE BREWING COMPANY 15.17 196.70" & @CRLF & _
"166 BEER VALLEY BREWING COMPANY 20.47 191.21" & @CRLF & _
"167 TWO SHY BREWING 17.00 187.50" & @CRLF & _
"168 GRIXSEN BREWING COMPANY 8.90 183.82" & @CRLF & _
"169 BANDON RAIN 36.03 183.63" & @CRLF & _
"170 OPPOSITION BREWING COMPANY 14.98 175.84" & @CRLF & _
"171 HORSEFEATHERS & BIG HORSE BREW PUB 18.00 160.25" & @CRLF & _
"172 BENT SHOVEL BREWING 12.50 157.98" & @CRLF & _
"173 WET DOG CAFE & BREWERY 12.00 154.92" & @CRLF & _
"174 REACH BREAK BREWING 11.50 152.16" & @CRLF & _
"175 1859 CIDER CO 20.49 149.73" & @CRLF & _
"176 ALESONG BREWING & BLENDING 10.39 148.24" & @CRLF & _
"177 BACK PEDAL BREWING CO 10.50 147.58" & @CRLF & _
"178 SOLERA BREWERY 20.00 144.82" & @CRLF & _
"179 OREGON TRAIL BREWERY 29.62 142.94" & @CRLF & _
"180 PELICAN PUB & BREWERY 6.33 137.82" & @CRLF & _
"181 THREE MUGS BREWING COMPANY 13.55 130.99" & @CRLF & _
"182 LEGEND CIDER COMPANY 12.30 127.43" & @CRLF & _
"183 WALTZ BREWING 12.00 127.32" & @CRLF & _
"184 CONVERSION BREWING COMPANY 12.28 116.88" & @CRLF & _
"185 CHEHALEM VALLEY BREWING CO 14.77 116.72" & @CRLF & _
"186 BIER ONE BREWING 9.79 112.77" & @CRLF & _
"187 BREWERS UNION LOCAL 180 15.05 104.17" & @CRLF & _
"188 DECEPTION BREWING COMPANY 9.67 100.59" & @CRLF & _
"189 PORTLAND U BREW & PUB 9.00 97.50" & @CRLF & _
"190 RIDGEWALKER BREWING 5.00 94.00" & @CRLF & _
"191 LITTLE BEAST BREWING 13.46 85.61" & @CRLF & _
"192 CONNER FIELDS BREWING 10.50 85.50" & @CRLF & _
"193 LONG BREWING 9.88 77.48" & @CRLF & _
"194 RACK & CLOTH 5.09 76.31" & @CRLF & _
"195 OSMO'S ALEHOUSE 8.00 73.00" & @CRLF & _
"196 MISTY MOUNTAIN BREWING 15.00 72.00" & @CRLF & _
"197 LOOKINGGLASS BREWERY 5.18 65.90" & @CRLF & _
"198 1188 BREWING COMPANY 7.00 60.99" & @CRLF & _
"199 SILVER FALLS BREWERY 11.37 59.42" & @CRLF & _
"200 BORING BREWING CO 3.50 59.20" & @CRLF & _
"201 MOUNTAIN VIEW BREWING COMPANY 8.17 59.01" & @CRLF & _
"202 SMITH ROCK BREWING COMPANY 6.50 57.50" & @CRLF & _
"203 PORTAL BREWING COMPANY 4.33 54.00" & @CRLF & _
"204 5 CIDER 2.80 49.04" & @CRLF & _
"205 GATEWAY BREWING INC 2.13 47.89" & @CRLF & _
"206 GOLD RUSH CIDER 1.00 44.04" & @CRLF & _
"207 THE ALE APOTHECARY 4.61 42.95" & @CRLF & _
"208 SCOUT BEER 6.46 42.38" & @CRLF & _
"209 LEIKAM BREWING 5.50 35.93" & @CRLF & _
"210 AMBACHT BREWING 4.05 31.79" & @CRLF & _
"211 WERNER BREWING COMPANY 1.73 24.65" & @CRLF & _
"212 THE HOP HAUS 2.50 24.50" & @CRLF & _
"213 MOONSHRIMP BREWING 1.87 21.07" & @CRLF & _
"214 HONDO'S BREW & CORK 2.50 20.50" & @CRLF & _
"215 TONIC FOODS LLC 1.52 16.48" & @CRLF & _
"216 FUNHOUSE BREWS 0.92 15.95" & @CRLF & _
"217 KAISER BREWING COMPANY LLC 2.25 15.26" & @CRLF & _
"218 SIUSLAW BREWING 1.00 14.50" & @CRLF & _
"219 THE HOPPY BREWER 1.62 14.10" & @CRLF & _
"220 GOLDEN ROW CIDER 3.22 12.88" & @CRLF & _
"221 EVASION BREWING 4.55 12.86" & @CRLF & _
"222 STEENS MOUNTAIN BREWING COMPANY 1.10 12.09" & @CRLF & _
"223 THE HIVE TAPHOUSE 7.00 11.17" & @CRLF & _
"224 3 SHEETS BREWERY 2.50 10.33" & @CRLF & _
"225 DEEP SPACE BREWING / OUT OF THIS WORLD PIZZA 2.25 9.80" & @CRLF & _
"226 EATS & TREATS CAFE / BIERLY BREWING 0.58 9.79" & @CRLF & _
"227 SHADE TREE BREWING 0.23 8.57" & @CRLF & _
"228 CASCADE BREWING BARREL HOUSE 0.90 8.34" & @CRLF & _
"229 DRAPER GIRLS CIDER COMPANY 4.77 8.16" & @CRLF & _
"230 TIGER TOWN BREWING CO 2.00 8.00" & @CRLF & _
"231 RUNCIBLE CIDER 1.50 3.99" & @CRLF & _
"232 HOOD VIEW CIDERWORKS LLC 2.74 3.87" & @CRLF & _
"233 ARLINGTON CLUB 0.60 3.00" & @CRLF & _
"234 TABLE ROCK BREWING 0.33 2.83" & @CRLF & _
"235 MADCOW BREWING COMPANY 0.10 2.63" & @CRLF & _
"236 M CROW LLC 0.77 2.27" & @CRLF & _
""
Local $sSubst = "$1\t$2\t$3$4$5$6\t$7$8$9"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)