using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)\s*Hello.*world";
string substitution = @"";
string input = @"test 1
Hello
foo
bar
a better world
foo
bar
world
test 2";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}