package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^|\|)(r)(?:\||$)`)
var str = `r
sql|r|python
c
vba|r
r|java`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}