import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\/]*(\\/.*?):(.*)$";
final String string = "dregistry.service.local:4000/msi/paas-cluster-manager:2.2.141401\n"
+ "dregistry.service.local:4000/paas-cluster-manager:2.2.141401";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}