package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<img.+?src=["'](.+?)["'].*?>`)
var str = `// it shouldn't match custom tag 'imgs-tag'
<imgs-tag class="hero-class" src="image.jpg">
// it shouldn't match custom attribute 'data-src'
<img data-src="custom info" src="image.jpg">
// it should match whole src attribute, not just part
<img class="hero-class" src="mcdonald's.jpg">
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}