$re = '/cdn.discordapp.com\/attachments\/[\d\w\/]+.(png|jpg|gif)/i';
$str = 'imgur.com/ghOCjsn
imgur.com/a/Tkyl6
i.imgur.com/ghOCjsn.png
i.imgur.com\\/[\\d\\w]+.(png|jpg|gif)
https://cdn.discordapp.com/attachments/738526872186650694/759759076715528253/image0.jpg
https://cdn.discordapp.com/attachments/650589304308891648/761662319209349140/ww.png
https://cdn.discordapp.com/attachments/764157854512316496/764160227506782228/E.docx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);