$re = '/\D+[A-Z]+/';
$str = 'ZWARTEBERGLAAN 6
\'T KLOOSTERHOF 34
34 JAN HAMMENECKERSTRAAT
JAN HAMMENECKERSTRAAT 34
CHEMIN DE P\'TIT ROUGE 6
AVENUE HENRI DE BROUCK�RE 31
L.A. SCHOOKLAANSTRAAT 42
HUIDEVETTERKEN 9-11-13-13 9
KONINGIN ASTRIDSTRAAT 316
BOULEVARD SAINT MICHEL 113//115 Verd.3
ANTWERPSESTEENWEG 83/101 Verd.1
AVENUE EMILE MAX 75 Verd.RC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);