$re = '/[A-Z]{1,10}-\d+/m';
$str = 'BUG-124
BUGG-124
feature/GUB-12
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);