import Foundation
let pattern = #"^(?:(?:(?=a+((?(1)\1)b))a)*\1)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Yes:
ab
aabb
aaabbb
aaaabbbb
aaaaabbbbb
No:
a
b
aaa
aab
abb
bbb
aaaa
aaab
abbb
bbbb
aaaaa
aaaab
aaabb
aabbb
abbbb
bbbbb
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)