import Foundation
let pattern = #"[^\s<>]+(?![^<]*>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en"><head><meta http-equiv="Content-Type" content="text/html;" /><title>Email Newsletter</title></head><body style="font-family: Helvetica, Arial, sans-serif; font-size: 12px">
<p><span style="font-size:14px;"><span style="font-family:arial,helvetica,sans-serif;">Hi %%first_name%% - hope you can join us!<br>
<br>
<a href="https://xfinityflowershow.rsvpify.com/"><img alt="" border="0" height="525" src="http://go.pardot.com/l/292992/2019-02-26/3yvjz3/292992/83766/FlowerShow_Invite_V4.jpg" style="height: 525px; width: 700px; border-width: 0px; border-style: solid;" width="700"></a><br>
<br>
Regards,<br>
%%user_name%%<br>
%%user_email%%<br>
Comcast</span></span><br>
<br>
<br>
<br>
<br>
<br>
<br>
<span style="font-size:10px;"><span style="font-family:arial,helvetica,sans-serif;">If you have received this communication in error or would like to unsubscribe, please click <a href="%%unsubscribe%%">here</a>. </span></span></p>
</body></html>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)