#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)[+]?(?<!\d)(?<!\d[ -])" & @CRLF & _
"(?:" & @CRLF & _
" ((\d{1,2}[ -]?)?[(]?\d{3}[)]?[ -]?)" & @CRLF & _
" (\d(?:[ -]?\d){3,6})" & @CRLF & _
")(?![ -]?\d)"
Local $sString = "Matches:" & @CRLF & _
"--------" & @CRLF & _
" 1234567 123 45 67 123-45-67 " & @CRLF & _
" 123456789012 12 345 678 9012 12-345-678-90-12 " & @CRLF & _
" 1 234 56 78 912 1 234 56 789 12 1 234 567 8 901 " & @CRLF & _
" +1234567 " & @CRLF & _
" +1234567890 +12-234 561 78 90 +12 234-561-78-90" & @CRLF & _
" +123456789012 " & @CRLF & _
" +1 234 561 78 90 " & @CRLF & _
" 1(234)567-89-01 " & @CRLF & _
" (495)1234567 (495) 123 45 67 " & @CRLF & _
" +33 (014)-020 53 17" & @CRLF & _
"" & @CRLF & _
"Doesn't match: " & @CRLF & _
"--------------" & @CRLF & _
" +123456 -- to short" & @CRLF & _
" +1234567890123 -- too long" & @CRLF & _
" 123 4567890123 -- too long"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")