const regex = /(¬zinit)(?<remaining_command>(?<simple_remaining>.+$(?<![\\'"]))|(?<continuation_line>.+(?<continuation>(?<slash_continuation>[\\]\n)|(?<quoted_continuation>["]\n[\s\S]*(?<!(?:[\\]{2})*[^\\])["])))*.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(¬zinit)(?<remaining_command>(?<simple_remaining>.+$(?<![\\\\\'"]))|(?<continuation_line>.+(?<continuation>(?<slash_continuation>[\\\\]\\n)|(?<quoted_continuation>["]\\n[\\s\\S]*(?<!(?:[\\\\]{2})*[^\\\\])["])))*.+)', 'gm')
const str = `¬zinit light-mode for \\
psprint/zsh-cmd-architect \\
psprint/zsh-editing-workbench
¬zinit light-mode for agkozak/zhooks
¬zinit atclone"dircolors -b LS_COLORS > c.zsh" \\
atpull'%atclone' \\
pick"c.zsh" \\
nocompile'!' \\
atload'zstyle ":completion:*" list-colors "\${(s.:.)LS_COLORS}"' \\
for disco0/LS_COLORS
¬zinit atclone"
autoload -Uz \\\${PWD}/functions/zcolors || {
builtin print -Pu2 -- \\
'%F{1} \\"WARNING: Failed to autoload zcolors command for initialization.%f\\";
return 1
};
zcolors \$LS_COLORS >! ~/.zsh/zcolors.zsh
" \\
atpull'%atclone' \\
pick"c.zsh" \\
nocompile'!' \\
atload'zstyle ":completion:*" list-colors "\${(s.:.)LS_COLORS}"' \\
for marlonrichert/zcolors
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}