use strict;
my $str = '¬zinit light-mode for \\
psprint/zsh-cmd-architect \\
psprint/zsh-editing-workbench
¬zinit light-mode for agkozak/zhooks
¬zinit atclone"dircolors -b LS_COLORS > c.zsh" \\
atpull\'%atclone\' \\
pick"c.zsh" \\
nocompile\'!\' \\
atload\'zstyle ":completion:*" list-colors "${(s.:.)LS_COLORS}"\' \\
for disco0/LS_COLORS
¬zinit atclone"
autoload -Uz \\${PWD}/functions/zcolors || {
builtin print -Pu2 -- \\
\'%F{1} \\"WARNING: Failed to autoload zcolors command for initialization.%f\\";
return 1
};
zcolors $LS_COLORS >! ~/.zsh/zcolors.zsh
" \\
atpull\'%atclone\' \\
pick"c.zsh" \\
nocompile\'!\' \\
atload\'zstyle ":completion:*" list-colors "${(s.:.)LS_COLORS}"\' \\
for marlonrichert/zcolors
';
my $regex = qr/(¬zinit)(?<remaining_command>(?<simple_remaining>.+$(?<![\\'"]))|(?<continuation_line>.+(?<continuation>(?<slash_continuation>[\\]\n)|(?<quoted_continuation>["]\n[\s\S]*(?<!(?:[\\]{2})*[^\\])["])))*.+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}