re = /(¬zinit)(?<remaining_command>(?<simple_remaining>.+$(?<![\\'"]))|(?<continuation_line>.+(?<continuation>(?<slash_continuation>[\\]\n)|(?<quoted_continuation>["]\n[\s\S]*(?<!(?:[\\]{2})*[^\\])["])))*.+)/m
str = '¬zinit light-mode for \\
psprint/zsh-cmd-architect \\
psprint/zsh-editing-workbench
¬zinit light-mode for agkozak/zhooks
¬zinit atclone"dircolors -b LS_COLORS > c.zsh" \\
atpull\'%atclone\' \\
pick"c.zsh" \\
nocompile\'!\' \\
atload\'zstyle ":completion:*" list-colors "${(s.:.)LS_COLORS}"\' \\
for disco0/LS_COLORS
¬zinit atclone"
autoload -Uz \\${PWD}/functions/zcolors || {
builtin print -Pu2 -- \\
\'%F{1} \\"WARNING: Failed to autoload zcolors command for initialization.%f\\";
return 1
};
zcolors $LS_COLORS >! ~/.zsh/zcolors.zsh
" \\
atpull\'%atclone\' \\
pick"c.zsh" \\
nocompile\'!\' \\
atload\'zstyle ":completion:*" list-colors "${(s.:.)LS_COLORS}"\' \\
for marlonrichert/zcolors
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end