$re = '/\p{Cs}/m';
$str = 'This test string has twenty (20) emoji π₯ππ₯°ππΌπ―π§ππΆππππ¨π¦π―π²π½πππ.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);