const regex = new RegExp('from group (\\d+)(?:(?!Temp).)*?(Temp)?(?:(?!Temp).)*?\\\\t(.*? ALL-..)', 'gm')
const str = `{"show permission allowed to 16": "show permission to 16\\\\nSchool permissions from group 17:student to group 16:teacher:\\\\n\\\\tAllow ALL-00\\\\nSchool permissions from group 18:library to group 16(Temp):teacher:\\\\n\\\\tNo Allow ALL-00\\\\nSchool permissions from group 20:Gym to group 16:teacher:\\\\n\\\\tCheck ALL-00\\\\nRTYAHY: FALSE\\\\nRTYAHY: FALSE\\\\n\\\\n#"}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}