# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=.\n)(.+)\n(?=.)/$1 /gm;t' <<< "ChapterName
text text text
text text text
text text text
AnotherChapterName
text text text
text text text
text text text
AnotherChapterName
text text text
text text text
text text text
"