package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)public\s+\$version\s+?=\s+'`)
var str = `public $version = '1.1.1'
some words before public $version = '1.1.1'
public $version = '1.1'
public $version = '1.1.10'
public $version = '1.1.10.1'
public $version = '10.1'
public $version = '10.1.10'
public $version = '10.10.10'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}