using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"attachment_types\"":(\""|)\[(.*?)\]";
string input = @"foo Section 7 - Delivering Terminal Diagnosis's
and then bar Section 7. Delivering a Terminal Diagnosis
see Section 7. Delivering a Terminal Diagnosis
filed under Section 7. Delivering a Terminal Diagnosis
Section 7 - Delivering Terminal Diagnosis's
Section 7. Delivering a Terminal Diagnosis
filed under Section 7. Delivering a Terminal and
see Section 7. Delivering a Terminal Diagnosis
filed under Section 7. Delivering a Terminal Diagnosis
""attachment_types"":""[yada yada yada]
""attachment_types"":[yada yada yada]
asf
a";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}