package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`defmodule ([a-zA-Z]+) do\n([\s\S]*)end`)
var str = `defmodule Test do
def dupa(a, b) do
a + b
end
end`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}