Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
defmodule ([a-zA-Z]+) do\n([\s\S]*)end
/
Input 1
1
New
defmodule Test do def dupa(a, b) do a + b end end