import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\((\\d+)\\)\\s+([^\\(]+)\\(([^\\)]+)\\)\\s+vs\\.\\s+\\((\\d+)\\)\\s+([^\\(]+)(.*)$";
final String string = "(8) Cincinnati (22-10) vs. (9) Purdue (21-12)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}