using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"&\w+=([\w,-]+)";
string input = @"?cgan=1&product_cats=mens-jeans,shirts&product_tags=fall,classic-style&attr_color=charcoal,brown&attr_size=large,x-small&cnep=0";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}