re = /&\w+=([\w,-]+)/
str = '?cgan=1&product_cats=mens-jeans,shirts&product_tags=fall,classic-style&attr_color=charcoal,brown&attr_size=large,x-small&cnep=0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end