re = /^(\.[\w.]+|[\w.]+\.)$/m
str = 'brew.pixels
brew.pixels
dfg21.dfgd
brew.pixels.
.brew.pixels'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end