using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(d|b y|toy);([^;\r\n]*);([^;\r\n]*)).*\R";
string substitution = @"$3";
string input = @"
a;; z
toy;d;hh
z;
d;23
;;io;
b y;b;12
a;b;bb;;;34
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}