import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(d|b y|toy);([^;\\r\\n]*);([^;\\r\\n]*)).*\\R";
final String string = "\n"
+ "a;; z\n"
+ "toy;d;hh \n"
+ "z;\n"
+ "d;23\n"
+ ";;io;\n"
+ "b y;b;12\n\n"
+ "a;b;bb;;;34\n"
+ " ";
final String subst = "$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}