re = /^(?!(d|b y|toy);([^;\r\n]*);([^;\r\n]*)).*\R/m
str = '
a;; z
toy;d;hh
z;
d;23
;;io;
b y;b;12
a;b;bb;;;34
'
subst = '$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result