import Foundation
let pattern = #"^(?!(d|b y|toy);([^;\r\n]*);([^;\r\n]*)).*\R"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
a;; z
toy;d;hh
z;
d;23
;;io;
b y;b;12
a;b;bb;;;34
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)