using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|\G)( {4}|\t)";
string substitution = @"\t";
string input = @"<?php
class SomeClass
{
var $property = 1;
function double(int $x)
{
$result = $x + $x;
// line already indented with tabs
// line started with tab, but followed with spaces
// line has 4 spaces in the middle
// line endings with 4 spaces
return $result;
}
}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}