#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\S+):\s*{\s*(((\S+):\s*"{{0,2}([^"{}]*)}{0,2}"\s*,?\s*)+)}"
Local $sString = "{" & @CRLF & _
" title1: {" & @CRLF & _
" x: "abc"," & @CRLF & _
" y: "def"" & @CRLF & _
" } ," & @CRLF & _
"" & @CRLF & _
" title2:{" & @CRLF & _
" x: "{{abc}}"," & @CRLF & _
" y: "{{def}}"" & @CRLF & _
" }," & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")