using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S+):\s*{\s*(((\S+):\s*""{{0,2}([^""{}]*)}{0,2}""\s*,?\s*)+)}";
string input = @"{
title1: {
x: ""abc"",
y: ""def""
} ,
title2:{
x: ""{{abc}}"",
y: ""{{def}}""
},
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}