# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[^\n~]+~[^\n~\\]+(?:\\[^\n~]+~[^\n~\\]+)+$"
test_str = ("SS~B66\\88~PRELIMINARY PAGES\\M01~HEADING PAGES\n"
"SS~B66\\88~PRELIMINARY PAGES~HEADING PAGES\n"
"SS~B66~PRELIMINARY PAGES\\M01~HEADING PAGES\n\n"
"SS~B66\\88~MEKLKE\\M01~MOIIE\n"
"B~A310\\0~PRELIM@INARY\\00-00~HEADING")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.