re = /^[^\n~]+~[^\n~\\]+(?:\\[^\n~]+~[^\n~\\]+)+$/m
str = 'SS~B66\\88~PRELIMINARY PAGES\\M01~HEADING PAGES
SS~B66\\88~PRELIMINARY PAGES~HEADING PAGES
SS~B66~PRELIMINARY PAGES\\M01~HEADING PAGES
SS~B66\\88~MEKLKE\\M01~MOIIE
B~A310\\0~PRELIM@INARY\\00-00~HEADING'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result