import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b((?!(?:.\\B)*(?:\\B.)*\\1)[dog]+)\\b";
final String string = "dog\n"
+ "gos\n"
+ "aegihl;iaei\n"
+ "brog\n"
+ "go\n"
+ "god\n"
+ "dooooog";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}