re = /import sel\./
str = 'package blah.foo.bar;
import org.blah.blah;
import sel.this.that;
import sel.boo.foo;
more text";'
subst = 'import sel.gen.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result