import Foundation
let pattern = #"import sel\."#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
package blah.foo.bar;
import org.blah.blah;
import sel.this.that;
import sel.boo.foo;
more text";
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"import sel.gen."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)