const regex = /(?:^|\G).*?([\w_]+\.(?:jpg|wmv))/sg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|\\G).*?([\\w_]+\\.(?:jpg|wmv))', 'sg')
const str = `output 1
abc.jpg
def.jpg
fgh.jpg
output 2
_01.wmv
_02.wmv
_03.wmv`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);