$re = '/(?:^|\G).*?([\w_]+\.(?:jpg|wmv))/s';
$str = 'output 1
abc.jpg
def.jpg
fgh.jpg
output 2
_01.wmv
_02.wmv
_03.wmv';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;