import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9a-fA-F]{2})([0-9a-fA-F]{2})([0-9a-fA-F]{2})([0-9a-fA-F]{2})([0-9a-fA-F]{2})([0-9a-fA-F]{2})([0-9a-fA-F]{2})([0-9a-fA-F]{2})([0-9a-fA-F]{2})([0-9a-fA-F]{2})([0-9a-fA-F]{2})([0-9a-fA-F]{2})([0-9a-fA-F]{2})([0-9a-fA-F]{2})([0-9a-fA-F]{2})([0-9a-fA-F]{2})";
final String string = "60060160d63036007ff161103ed5e311\n"
+ "60060160d6303600c659771b3ed5e311\n"
+ "60060160d630360089338aa421b1e311\n"
+ "60060160d6303600990f61b521b1e311\n"
+ "60060160d6303600367d84115d58e411\n"
+ "60060160d430360087eacc151270e411\n"
+ "60060160d63036008cf99f0240b1e311";
final String subst = "\\1:\\2:\\3:\\4:\\5:\\6:\\7:\\8:\\9:\\10:\\11:\\12:\\13:\\14:\\15:\\16";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}