using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^##api(?<apicont>.+?)##.+?Функция\s+(?<funcname>.+?)\((?<funcparam>.+?)\)\s+{";
string input = @"##api
# @param лс - обязательный параметр. row_id ЛСа/дома/квартира
# @param наДату - обязательный параметр. Дата, на которую должена действовать УК
# @param результат - не обязательный параметр. Может быть только строкой (ЛСID, УКДатНач, УКДатКнц, ОрганизацияID, Название, Наименование, ДоговорID, Номер, ККС, ДоговорДатНач, ДоговорДатКнц, Объект_Организация, Объект_Договор), по умолчанию - пустая строка, определяет что вернуть в качестве результата, массив, конкретное поле или объект
# @param дом - не обязательный параметр. row_id дома, для проверки кеша
# @description возвращает массив с собранными данными об УК
##
Функция ПолучитьУКпоЛС(лс, наДату, ...) {
##api
# @param лс - обязательный параметр. row_id ЛСа/дома/квартира
# @param наДату - обязательный параметр. Дата, на которую должена действовать УК
# @param результат - не обязательный параметр. Может быть только строкой (ЛСID, УКДатНач, УКДатКнц, ОрганизацияID, Название, Наименование, ДоговорID, Номер, ККС, ДоговорДатНач, ДоговорДатКнц, Объект_Организация, Объект_Договор), по умолчанию - пустая строка, определяет что вернуть в качестве результата, массив, конкретное поле или объект
# @param дом - не обязательный параметр. row_id дома, для проверки кеша
# @description возвращает массив с собранными данными об УК
##
Функция ПолучитьУКпоЛС(лс, наДату, ...) {";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase | RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}