using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/([bi])((?<=b)o|(?<=i)t)\s+([\w]+)";
string substitution = @"<$1>$3</$1>";
string input = @"Hello, isn't the /bo weather just /it beautiful. today!?";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}