import Foundation
let pattern = #"\/([bi])((?<=b)o|(?<=i)t)\s+([\w]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Hello, isn't the /bo weather just /it beautiful. today!?"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<$1>$3</$1>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)