use strict;
my $str = 'calle prueba, 2
calle de la prueba, 5
Avenida de la prueba, 5
Plaza de la prueba, 5
Calle Higuereta, 4, 7º B
Calle Escritor Conde Zamora s/n
Avenida Ciudad de Aranjuez 18
Avenida Pintor Sorolla 125 4ºG
Polígono Industrial Aranguren 6
Calle Gremi Passamaners 24 2º
Avenida Manuel Rodriguez Ayuso, 170
Calle Illa de Buda 55
C/ Walia, 21
C/Alfonso Pesquera, 6';
my $regex = qr/^([cC]\/|[cC]alle|[aA]v\/|[aA]venida|[pP]laza\/|[pP]laza)\s([A-z ]{0,})\,\s\d+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}