const regex = new RegExp('[._-](?=[^@]*@)', 'gm')
const str = `ab_cd_123@email.com`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);