#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?|^\s*(\p{S}).*$|^.*(\p{S})\s*$|^.*?(\p{L}{1,6})\s*$)"
Local $sString = "$19.99" & @CRLF & _
"19.99" & @CRLF & _
"19.99 EUR" & @CRLF & _
"19.99$ CAD" & @CRLF & _
"19.99 E" & @CRLF & _
"19.99 $" & @CRLF & _
"$ 19.99" & @CRLF & _
"$ 19.99 USD"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")