using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"~\/remove\/me[^\s]*\/(?=[^\s]+)";
string substitution = @" ";
string input = @"~/remove/me/myexec.pl /some/other/path/exec.pl
/yet/another/path/pipeit.pl | ~/remove/me/subdir/tome.pl
~/remove/me/deeply/nested/exec.pl";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}