import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "~\\/remove\\/me[^\\s]*\\/(?=[^\\s]+)";
final String string = "~/remove/me/myexec.pl /some/other/path/exec.pl\n"
+ "/yet/another/path/pipeit.pl | ~/remove/me/subdir/tome.pl\n"
+ "~/remove/me/deeply/nested/exec.pl";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}